'86 Comanche Long bed, Slow build...

#61
That looks great. Good to see it up and running, you had a major project going. What's next doing an extended cab Comanche? My brother and father both bought new '87s. Loved them just found it hard to get comfortable, I always wanted the seat to move back further. One had buckets and the other bench and they both felt the same.
If I remember correctly, wasn't the firewall modified in '87 to allow room for the long 4.0.

Jim
Next... bed rack/ soft topper to hold the RTT. And Monstaliner in the bed. The firewall on the 86's was indeed not the same as 87 up, and you have to beat it to fit a 4.0l. That made the 3.4 v-6 a much easier swap.
 
#65
Any updates to this truck OP?
Wow, I owe this thread an update!

I built a bed rack and mounted a RTT for the summer. We took it camping several times and it was awesome.

I was getting convinced that it had a head gasket issue, but a different radiator cap seems to have fixed that.

My wife drives it daily and it really is working well. I'll find some pictures from camping this summer and post them later.
 
#67
Damn too bad photobucket killed all your pics, I would love see them.
You weren't kidding that timing chain is looooooose!
I'll try to get them migrated to expo soon, but in the meantime, there IS a workaround for some browsers!!
Search "photobucket hotlink fix". You'll see apps for Firefox and Chrome. (If you're not using one of those two browsers, you need to start.)
All you have to do is find the app, click the "install" button, and voila, pictures show up!
Enjoy,
Chris
 
#68
I'll try to get them migrated to expo soon, but in the meantime, there IS a workaround for some browsers!!
Search "photobucket hotlink fix". You'll see apps for Firefox and Chrome. (If you're not using one of those two browsers, you need to start.)
All you have to do is find the app, click the "install" button, and voila, pictures show up!
Enjoy,
Chris
You, sir, are a saint.
 
#69
I'll try to get them migrated to expo soon, but in the meantime, there IS a workaround for some browsers!!
Search "photobucket hotlink fix". You'll see apps for Firefox and Chrome. (If you're not using one of those two browsers, you need to start.)
All you have to do is find the app, click the "install" button, and voila, pictures show up!
Enjoy,
Chris
Frig Thank you so much! I had no idea that fix was out there.
Seriously wicked build. Absolutely love the tan/black colour scheme. Comanches are so rare around here now.