Dometic propane frig odd problem


Expedition Leader
This is in a 94 Northstar (Texson) TS 1000 with 3 way frig. Owned about 5 yrs. Propane side of frig has worked fine apart from blowing out while driving. Got it out of storage for first trip this season. Hard to light the propane. It's got the push button thermocouple gas bypass and piezio ignition with a viewing prism. Lights on first or second spark with a moderate flame but flame then dies out even with button pushed. Finally stayed lit after about 20 tries. Same problem each time it went out when driving. Very hard to stay lit but once it stays lit long enough to warm the thermocouple it runs. It seems like it's running out of gas even with the button pushed. I think it has enough oxygen since the flame is blue and not yellow. When I got home I removed my wind baffle and the OE cover and watched it while my wife started it. It started perfectly fine then. No evidence of dirt or cobwebs once I removed the covers. Anyone have any ideas or experienced this? Almost seemed as if the gas push button provided enough gas initially but then stopped passing gas.


Light your stove and let both burners run for a minute or so. This will totally bleed the system as the stove is 3rd in line for propane "large air pocket" and may fix the problem.


Supporting Sponsor, Overland Certified OC0018
Have you tried cleaning the thermocoupler?

Sometimes they get a deposit on them where the flame contacts the probe. A small wire brush will usually take care of it.


Expedition Leader
I did run both burners of the stove before trying the light the frig. I always do that to get the air out. The problem persisted even after cooking a couple of meals and running the hot water heater and furnace. But you're right, it was acting like there was still air in the line. But even after running the frig overnight for the first time, the problem persisted when I tried to relight it.
I have cleaned the thermocouple with a wire brush in the past, but in this case, it doesn't seem to be the problem because the flame goes out even with the push button pushed in so it's not burning large enough or long enough to warm the thermocouple. Once I was able to get the flame to burn long enough with the button pressed in, the thermocouple activated and it stayed on.


Expedition Leader
I did try various settings and turning the gas/electric valve on and off a number of times. I couldn't detect any difference but you're right that those things control the gas flow and perhaps the problem is within the valve/thermostat.


Expedition Leader
Now that you mention it, it reminds me that I've had a similar problem on a 24 volts gas valve on a house furnace. Very slow to move to let gas thru. Maybe there's not a direct mechanical connection between the push button and the gas valve and the gas valve is not completely opening when the push button is pushed. Anyone know how that push buttons opens the valve to let gas flow?


Expedition Leader
I think the thermocouple can be ruled out because the problem is occurring prior to the thermocouple coming into play.

Forum statistics

Latest member