Latest Photo?

MTSN

Explorer
I think I ran into your group on the dead end section of Hell's Revenge headed to the river overlook. I was in the white Power Wagon with cap waiting at one of the ledge obstacles headed out as you were headed in. As I recall there were more than a couple Land Cruisers in your group...
Very likely. I was leading a group for Cruise Moab on Thursday 5/2, and I had 20 trucks total in my convoy. We surprisingly had a total of 5 200s and 4 100s and some 80s of course. Quite a few Cruisers turned out, and we had a great day.

 

JPR4LFE

Adventurer
Very likely. I was leading a group for Cruise Moab on Thursday 5/2, and I had 20 trucks total in my convoy. We surprisingly had a total of 5 200s and 4 100s and some 80s of course. Quite a few Cruisers turned out, and we had a great day.

Yes it would have been Thursday 5/2, I was on the trail solo that day. I was definitely drooling over many of the Land Cruisers as I waited, both classic and new school alike. Between Power Wagons In Moab (PWIM) and the Bronco Safari in town that week, there was plenty to drool over, no matter your preference :)
 

barnsey

Member
Fired the 12ht up this afternoon. was surprised when it fired up first kick, I chucked all the vacuum lines over my shoulder except for one, then removed the heater from inside the intake & ported & polished the intake, then removed all the vacuum switching & wiring for the shutoff valve, i will use a simple choke cable hooked up to the shutoff butterfly to stop the engine, the motor sounded great with no knocks or rattles & the rockers sounded pretty quite as well,
Now its running i can start putting my cruiser back together after work each afternoon this week & hopefully get some k's on it next weekend,
this is the only video i have so far of it running, I only ran it twice for a short time & i need to get the radiator back in, oil pressure was also pretty good so happy days
upload_2019-5-20_21-18-33.gif

video on instagram
http://instagr.am/p/BxrP_Lfne2R/
517306
 
Top